
Excel 2003 Database for Windows 
 
 
 
Course Description 
 
Learn how to set up a database and how to use the data commands to manipulate the 
information. 
 
 
Intended Audience 
 
Anyone who has a need to organize and manage large amounts of data and to easily retrieve the 
data. 
 
 
Database Definition 
 
A database is a computerized record-keeping system. It is a tool for organizing, managing, and 
retrieving information. Its overall purpose is to maintain information and to make that 
information available on demand. The information can be anything that is of significance to an 
individual or organization. 
 
A database can be compared to a filing cabinet. A filing cabinet contains files of information 
stored in a certain sequence. Files in a filing cabinet are called records in a database. Specific 
information in a record is called a field. A group of fields make up a record and a group of 
records make up a database. A row of entries is recognized as a record. The individual cells by 
column are fields.  Each column may contain only one specific type of information for all the 
records. 
 
Consistency with data entry is important. Information such as dates, abbreviations, etc. should be 
consistent. 
 
At a minimum, a database is a cell range consisting of one or more columns and at least two 
rows.  The first row of the database contains field names and the following rows contain records. 
Usually a record consists of the name of some item (student, employee, equipment, etc.) and 
additional data pertaining to the item. 
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Database Parts 
 
 

 
 
 
Field names.  The first row labels are referred to as field names that identify the contents of each 
column. The field names are required. No two field names can be the same. Field names must be 
text. If a number is used as a field name it must be formatted as text. It is recommended that you 
keep field names short. Keeping the names short will allow you to view more of the database in 
one window.   
 
Fields.  Each column in a database is a separate field and each of the cells in a column is a field.  
Fields can contain text, numbers, dates or formula or a field can be blank. Break your 
information down into as small of fields as necessary to perform retrieval and sort functions. For 
example, if you want to sort or retrieve based on zip codes, make zip code a separate field from 
the city and state fields. 
 
Records.  A record is a single row in a database. Each record contains the same type of data as 
all other records in the database. 
 
The data commands are used for database management. Until you use the commands to process 
a database, it is just a collection of cell entries like a regular worksheet. In creating a database, 
you can use all of the Excel commands you use to create, revise, format and print a worksheet. 
 
 
Creating a Database 
 
 • Click on the Start button; choose All Programs> Microsoft Office> Microsoft Office 

Excel 2003 
 

•  Type the database shown on the next page 
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As you can see the database file was created just as you create a worksheet. 
 

• Move to cell E2 and select E2 through E12 
 

• To format our GPA column to two decimal places, choose Style under the Format menu; 
change the Style Name from Normal to Comma and click OK 

 
• Save your worksheet as class.xls 

Note: You can also use the Comma tool on the Formatting toolbar.   
 
 
Editing a Database 
 
A database is edited the same way as a worksheet. You can add or delete rows and columns, 
format cell entries, copy data, etc.  
 
It is possible to add a row at the end of other entries, even in the middle of a current database. To 
add a row, click on a cell in the place where you would like the row(s) added.  You do not need 
to click on any particular column. For example, we will add a record between Rows 8 and 9. 
 
 • Click any cell in Row 9 
 
 • Select the Rows command under the Insert menu 
  
 • Add the following record 
 
  Sowards, Susan    JR Biol 4 
  
To delete rows, you need to select the entire row(s). Otherwise, Excel will simply delete 
particular cells, move other cells to fill in the space, and your records will be misaligned.   
 • Highlight the entire first record containing Smith, Joseph by clicking on the Row number 
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 • Choose Edit> Delete 
 
We do not need to restore the record since it is a duplicate, but if you did, you would choose 
Edit> Undo. 
 
 
Data Series 
 
The Data Series command is used to fill a range with a sequence of numbers in ascending or 
descending order with a specified increment or decrement. Using the example database, we will 
assign numbers to each record. 
 

• Move to cell A2 and type 1 and press <Enter> 
 

•  Select cells A2 through A12 
 

•  Choose Edit> Fill> Series 
 

 
 

• In the Series dialog box make sure the Step Value is 1 and then click the OK button 
 
 • Click anywhere to deselect 
 
One reason for numbering the records is that if you sort the database and then want to restore it 
to its original order, you can use the numbers to sort on. 
 
The Data Series command can be used with any type of worksheet; not just a database. 
 
 
Data Sort 
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You may want to change the order of your database records. You can sort the list of students in 
our example database alphabetically by name, class or major, or numerically sort the GPA in 
ascending or descending order.  
 
We will first sort the records alphabetically by class and then the student names alphabetically 
within the class. 
 

• Choose the range to sort:  cells A1 through E12  
 

• Choose Data> Sort 
 

 
 
 • In the first “Sort by” option box, choose Class 
 
 • In the “Then by” option box, choose Name  
 

• Click the OK button 
 
You can use the Undo Sort command on the Edit menu to immediately restore your database to 
its original order or you can do it by sorting on the Student ID field. 
 
 • Restore your database to its original order 
 
 • Click anywhere to deselect 
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You can sort on more than three field names by sorting two or more times. Since the most recent 
sort takes precedence, the first three field names should be the least important fields. Of those 
three fields, use the most important as the first field name, the next most important as the second 
field, and the least important as the third field. Then sort using the next three field names, again 
using the most important of the three as the first field. 
 
 
Data Form 
 
A data form is a dialog box that provides an alternative way to view, change, add and delete 
records in your database. You can view one complete record at a time. The data form can display 
only a maximum of 25 fields and you cannot scroll through the fields as you can when viewing 
in the worksheet format. 
 
The data form can be used to initially set up a database and then enter your records rather than 
typing in the records in the usual worksheet format.  
 
When using the data form method to set up your database, type your field names, select the field 
names and then use the Form command on the Data menu. 
 
We will insert another record in our database using the data form. Make sure a cell is selected in 
your current database. 
 
 • Choose Data> Form 
 

 
   
   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Notice in the upper right corner 
the first record is listed in addition 
to the number of records in your database. 
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 • Click the New button and type the following information in the appropriate fields: 
  Note: Do not press <Enter> after each field, press <Tab> instead 
 
  12          Allen, Sandy  SR Engl       3.5 
  
 • Press <Enter> and the record appears in the database 
 
  Use the Find Prev and the Find Next buttons to move between the records in the Data 

Form. 
 
 
Deleting Records 
 
The Delete button will remove the displayed record. Excel will prompt with a dialog box giving 
you the opportunity to cancel. 
 
 
Finding Records Using the Data Form 
 
The data form can be used to find records quickly in your database. 
 
 • Click on the Criteria button 
 
  The record number indicator 

changes to the word ‘Criteria’, the 
Criteria button changes to Form 
and the Delete button changes to 
Clear. The Clear button clears all 
existing criteria. 

 
 • In the Name field type in Sowards 
 
 

 
 
 
 
 
 
 
 
 

The Find Next button searches forward in the database and the Find Prev button searches 
backward in the database. 
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 • Click the Find Prev button - depending on where you are in the records, you may need to 
click the Find Next button 

 

 
 
 
Changing Criteria  
 

• Click the Criteria button 
 
 • Delete Sowards in the Name field 
 
 • Enter SR for the Class field 
 

• Select Find Prev or Find Next to find matching records 
 
 
Searching For Multiple Criteria 
 
 • Click on the Criteria button 
 
 • Enter FR  in the Class field 
  
 • In the Major field, type Econ 
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 • Click Find Prev or Find Next 
 
 
Searching for Values 
 
If you want to search for exact values, enter the value as the criterion. The format does not need 
to match the format of the value in the database. For example, $35 matches 35 or  35.00. You 
can also search for values that meet a condition, such as all entries greater than 3.75 for the GPA. 
We will find all GPAs greater than 3.75.  
 
 • Click on the Criteria button  
 

• Clear the criterion previously entered  
 

• In the GPA field, type >3.75  
 
 • Click on Find Prev or Find Next 
 
 
Editing Records During a Find 
 
When using the Form, you can edit the records you find. Move to the record you want to edit, 
select the appropriate cell and make your corrections. 
 
 • Move to John, James 
 

•  Select the Class field and change to a SO 
 

• Move to the Major field 
 

• Change the Major to Engl 
 
 • Click the Close button 
 
 
 Filtering a List Using AutoFilter 
 
AutoFilter enables you to display a subset of your list according to different criteria.   
 
 • Choose Data> Filter> AutoFilter 
  
  You should see drop-down arrows next to each column label. The item you select in a 

column drop-down list is called the filter criterion.   
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 • To make a filtered list of all Economics majors, choose Econ in the drop-down box next 
to the Major column heading 

 

 
 
 
You can filter your list further by choosing another criterion from another column. 
 
 • To make a filtered list of all senior Economics majors, click on the drop-down box next 

to the Class column heading and choose SR 
 
 • To view all of the records again, click on the Major drop-down box again, choose (All) 
 
 • Click on the Class drop-down box and choose (All)  
 
 
Using Custom Criteria with AutoFilter 
 
With AutoFilter, you can specify custom criteria for each column. This is useful when you want 
to display rows that contain either of two items in a text field, or to display rows that contain 
values that fall within a range of values. 
 
 • To make a filtered list of all students with GPAs between 2.5 and 3.75, click on the drop-

down box next to the GPA column heading and select (Custom...) 
 
 • Use the drop-down boxes to choose the comparison operators (equals, does not equal, is 

greater than, etc.) 
 
 • You can either type in the numerical values, or you can use the drop-down boxes to click 

and choose among values that appear in the database  
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 • Click the OK button 
  
 • Again, to show all of the records, choose (All) in the GPA drop-down box 
 
 
Extracting Records 
 
Extracting copies records matching your criteria from your database and lists them in a separate 
area of the worksheet. The easiest way to do this is simply obtain the subset of information 
through AutoFilter, and then copy it into another location on the worksheet using the copy and 
paste feature. 
 
 • Use AutoFilter to obtain a subset of all the economics majors  
 

• Highlight this block of data   
 
 • Choose Edit> Copy 
  
  There should be a “marching ants” border around each record selected while using 

AutoFilter.   
 
  You can show all of the records by selecting (All) in the drop-down box next to Major. 
 
 • Click on a cell below the rest of the records 
 
 • Select Edit> Paste 
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 • To exit the AutoFilter mode, choose Data> Filter> AutoFilter 
 

 
Linking Files 
 
You can link data from one cell in a worksheet or database to another file. This saves you from 
having to manually update information in two different files. For example, our database file 
contains all students enrolled at Macalester. We will make another file containing just the 
workstudy students. Every time a workstudy student changes departments or the dollar amount 
changes in the workstudy file, it will automatically update in our student database. 
 
 • Open a new worksheet 
 
 • Type the following information 
 

 
 
 
 • Save your workbook as workstudy 
 
 • Under the Window menu, choose your class workbook 
 

• Add two column labels: Workstudy Dept in F1 and Amount in G1 
 
The formula to set up links is:  =[name of workbook]name of worksheet!cell or range.  For 
example to link Sue’s department entry (stored in cell B2) in the workstudy database to the class 
database, the formula would be =[workstudy.xls]Sheet1!$B$2.  But you don’t have to type in 
the formulas.  To link the three workstudy students with the class database, do the following: 
 
 • Select cell F4 and type an = sign 
 
 • Using the Window menu switch to the workstudy workbook and click on the cell you 

want to link -- in this case B2 
 
 • Press the <Enter> key 
 
  You are immediately switched back to the class workbook -- notice the formula is filled 

in. 
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Finish the link for Sue for the salary (put it in G4) and then continue setting up the links for Tim 
(B3..C3) and Brenda (B4..C4). You can just type the formulas in if you don’t want to switch 
back and forth between the worksheets. 
 
 • In the workstudy workbook, change one of the salaries and one of the departments 
 
 • Switch back to class -- notice the entries are updated  
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