Excel 2004 Database for the Macintosh OS X

Course Description

Learn how to set up a database and how to use the data commands to manipulate the information.

Intended Audience

Anyone who has a need to organize and manage large amounts of data and to easily retrieve the
data.

Database Definition

A database is a computerized record-keeping system. It is a tool for organizing, managing and
retrieving information. Its overall purpose is to maintain information and to make that
information available on demand. The information can be anything that is of significance to an
individual or organization.

A database can be compared to a filing cabinet. A filing cabinet contains files of information
stored in a certain sequence. Files in a filing cabinet are called records in a database. Specific
information in a record is called a field. A group of fields make up a record and a group of
records make up a database. A row of entries is recognized as a record. The individual cells by
column are fields. Each column may contain only one specific type of information for all the
records.

Consistency with data entry is important. Information such as dates, abbreviations, etc. should be
consistent.

At a minimum, a database is a cell range consisting of one or more columns and at least two
rows. The first row of the database contains field names and the following rows contain records.
Usually a record consists of the name of some item (student, employee, equipment, etc.) and
additional data pertaining to the item.
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Field names. The first row labels are referred to as field names that identify the contents of each
column. The field names are required. No two field names can be the same. Field names must be
text. If a number is used as a field name it must be formatted as text. It is recommended that you
keep field names short. Keeping the names short will allow you to view more of the database in
one window.

Fields. Each column in a database is a separate field and each of the cells in a column is a field.
Fields can contain text, numbers, dates or formula or a field can be blank. Break your
information down into as small of fields as necessary to perform retrieval and sort functions. For
example, if you want to sort or retrieve based on zip codes, make zip code a separate field from
the city and state fields.

Records. A record is a single row in a database. Each record contains the same type of data as
all other records in the database.

The data commands are used for database management. Until you use the commands to process
a database, it is just a collection of cell entries like a regular worksheet. In creating a database,
you can use all of the Excel commands you use to create, revise, format and print a worksheet.
Creating a Database

* Double click the Excel icon to open (or single click the icon in the Dock)

e Type the database shown on the next page



< A B C D [ R
1 StudentID Name Class Major GPA

2 John, James SR wgst 3.45
3 Clements, Gerald SO Engl 4
< Smith, Joseph FR wagst 3.75
5 Anderson, Sue JR Hist 3.95
6 Smyth, Amy SO Math 2.33
7 Clawson, Barbara FR Math 3.25
8 Johnsen, Tim SO Math 3.75
9 Thomas, Connle FR Hist 3.75
10 Rex, Brenda SR wgst 2.5
11 Johnsen, Robert JR Engl 2.5
12 Smith, Joseph FR wWagst 3.75

As you can see the database file was created just as you create a worksheet. Save your file as
classlist.

*  Move to cell E2 and select E2 through E12

e To format our GPA column to two decimal places, choose Number from the Format
menu, under the Number section in the Formatting Palette.

Editing a Database

A database is edited the same way as a worksheet. You can add or delete rows and columns,
format cell entries, copy data, etc.

It is possible to add a row at the end of other entries, or even in the middle of a current database.
To add a row, click on a cell in the place where you would like the row(s) added. You do not
need to click on any particular column. For example, we will add a record between Rows 8 and
9.

*  Click any cell in Row 9

e Select the Rows command under the Insert menu

* Add the following record

Sowards, Susan JR Biol 4



To delete rows, you need to select the entire row(s). Otherwise, Excel will simply delete
particular cells, move other cells to fill in the space, and your records will be misaligned.

e Highlight the entire first record containing Smith, Joseph by clicking on the Row number
e Choose Edit> Delete

If you want to restore the record, click Undo Delete under the Edit menu or the Undo button on
the Standard toolbar.
Data Series
The Data Series command is used to fill a range with a sequence of numbers in ascending or
descending order with a specified increment or decrement. Using the example database, we will
assign numbers to each record.

*  Move to cell A2 and type [ (press <return>)

* Select cells A2 through A12

e Choose Edit> Fill> Series

A Series
Series in Type Date unit
) Rows ® Linear *) Day
@ Columns ; Growth Weekday
O Date Month
~ Trend ; AutoFill Year
Step value: 1 Stop value:

' Cancel ' &GK—a

* In the Series dialog box make sure the Step Value is 1 and then click the OK button

* Click anywhere to deselect



One reason for numbering the records is that if you sort the database and then want to restore it
to its original order, you can use the numbers to sort on.

The Data Series command can be used with any type of worksheet; not just a database.

Data Sort
You may want to change the order of your database records. You can sort the list of students in
our example database alphabetically by name, class or major, or numerically sort the GPA in

ascending or descending order.

We will first sort the records alphabetically by class and then the student names alphabetically
within the class.

* Choose the range to sort: cells Al through E12

¢  Choose Data> Sort

Sort
Sort by
Class @ ® Ascending
") Descending
Then by
Name @ ® Ascending
A _ Descending
Then by
@ @ Ascending
") Descending
My list has
@® Header row U No header row

' Options... ~ ' Cancel ' G—GK—)

e In the first Sort by option box, choose Class

e In the Then by option box, choose Name



¢ (Click the OK button

You can use the Undo Sort command on the Edit menu to immediately restore your database to
its original order or you can do it by sorting on the Student ID field.

* Restore your database to its original order
* Click anywhere to deselect

You can sort on more than three field names by sorting two or more times. Since the most recent
sort takes precedence, the first three field names should be the least important fields. Of those
three fields, use the most important as the first field name, the next most important as the second
field, and the least important as the third field. Sort using the next three field names, again using
the most important of the three as the first field. Continue sorting in this manner until you have
sorted using the most important field names.

Data Form

A data form is a dialog box that provides an alternative way to view, change, add and delete
records in your database. You can view one complete record at a time. The data form can display
only a maximum of 32 fields and you cannot scroll through the fields as you can when viewing
in the worksheet format.

The data form can be used to initially set up a database and then enter your records rather than
typing in the records in the usual worksheet format.

When using the data form method to set up your database, type your field names, select the field
names and then use the Form command on the Data menu. When prompted with either the
Office Assistant or a dialog box, click the OK button to accept your selected column labels as the
field names.

We will insert another record in our database using the data form. Make sure a cell is selected in
your current database.

¢ Choose Data> Form
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: ' Close '

Notice in the upper right corner the number of the current record is given in addition to
the number of records in your database.

e Click the New button and type the following information in the appropriate fields:
Note: Do not press <return> after each field, press <tab> instead.

12 Allen, Sandy SR Engl 2.5
e Press <return> and the record appears in the database

Use the Find Prev and the Find Next buttons to move between the records in the Form.

Deleting Records

The Delete button will remove the displayed record. Excel will prompt with a dialog box giving
you the opportunity to cancel.

Finding Records Using the Data Form

The data form can be used to find records quickly in your database.

¢ Click on the Criteria button



The record number indicator changes to the word ‘Criteria’, the Criteria button changes
to Form and the Delete button changes to Clear. The Clear button clears all existing
criteria.

In the Name field type in Sowards

Sheetl
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The Find Next button searches forward in the database and the Find Prev button searches
backward in the database.

Click the Find Prev button - depending on where you are in the records, you may need
to click the Find Next button
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Changing Criteria
*  Click the Criteria button
*  Click the Clear button
* Enter SR for the Class field

* Select Find Prev or Find Next to find matching records

Searching For Multiple Criteria
e (lick on the Criteria button and then the Clear button
e Enter FR in the Class field
e In the Major field, type Econ

¢ (Click Find Prev or Find Next



Searching for Values
If you want to search for exact values, enter the value as the criterion. The format does not need
to match the format of the value in the database. For example, $35 matches 35 or 35.00. You can
also search for values that meet a condition, such as all entries greater than 3.75 for the GPA. We
will find all GPAs greater than 3.75.

¢ (Click on the Criteria button and then the Clear button

e In the GPA field, type >3.75

¢  (Click on Find Prev or Find Next

Editing Records During a Find

When using the Form, you can edit the records you find. Move to the record you want to edit,
select the appropriate cell and make your corrections.

¢ Move to John, James

e Select the Class field and change to a SO
*  Move to the Major field

e Change the Major to Engl

¢ (Click the Close button

Filtering a List Using AutoFilter
AutoFilter enables you to display a subset of your list according to different criteria.
*  Choose Data> Filter> AutoFilter

You should see double arrows next to each column label. These are the Sort and Filter
drop-down menus.

10
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* Click on the down arrows in the Major column
The field you select in the list is called the filter criterion.
e To make a filtered list of all Women’s and Gender Studies majors, choose Wgst
You can filter your list further by choosing another criterion from another column.

* To make a filtered list of all senior Women’s and Gender Studies majors, click on the
double arrows next to the Class column heading and choose SR

* To view all of the records again, click on the Major double arrows again, choose (Show
All)

e Click on the Class double arrows and choose (Show All)

Using Custom Criteria with AutoFilter
With AutoFilter, you can specify custom criteria for each column. This is useful when you want
to display rows that contain either of two items in a text field, or to display rows that contain

values that fall within a range of values.

e To make a filtered list of all students with GPAs between 2.5 and 3.75, click on the
double arrows next to the GPA column heading and select (Custom Filter)

e Use the drop-down menus to choose the comparison operators (equals, does not equal, is
greater than, etc.)
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You can either type in the numerical values, or you can use the drop-down menus to click
and choose among values that appear in the database.

Custom AutoFilter

Show rows where:

GPA
is greater than ﬂ 2.4 @
®and O or
is less than or equal to el (3.75 @
Use ? to represent any single character k

Use * to represent any series of characters

' Cancel - ( oK )

Click the OK button

Again, to show all of the records, choose (Show All) in the GPA list

Extracting Records

Extracting copies records matching your criteria from your database and lists them in a separate
area of the worksheet. The easiest way to do this is simply obtain the subset of information
through AutoFilter, and then copy it into another location on the worksheet using the copy and
paste feature.

Use AutoFilter to obtain a subset of all the economics majors. Highlight this block of
data

Choose Edit> Copy

There should be a “marching ants” border around each record selected while using
AutoFilter.

You can show all of the records by selecting (Show All) in the drop-down menu next to
Major.
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¢ (Click on a cell below the rest of the records
¢ Select Edit> Paste
¢ To exit the AutoFilter mode, choose Data> Filter> AutoFilter

e Save your worksheet

Linking Files

You can link data from one cell in a worksheet or database to another file. This saves you from
having to manually update information in two different files. For example, our database file
contains all students enrolled at Macalester. We will make another file containing just the
workstudy students. Every time a workstudy student changes departments or the dollar amount
changes in the workstudy file, it will automatically update in our student database.

e Open a new workbook

Type the following information

< A B C
1 Name Department Amount
2 |Anderson, Sue Adm 1700
3 Smyth, Amy Math 2000
4 |Johnson, TIm Geog 1500

e Save your workbook as wkstudy
e Under the Window menu, choose Arrange and then Horizontal
Now you can see both your workbooks.

* In your first workbook, cell F1, type Department and in G1 type Salary
The formula to set up links is: =[name of workbook]name of worksheet!cell or range. For
example to link Sue’s department entry (stored in cell B2) in the wkstudy database to the classlist
database, the formula would be =[wkstudy.xIs]Sheet1!$B$2. But you don’t have to type in the
formulas. To link the three workstudy students with the classlist database, do the following:

e Select cell F5 in the classlist workbook and type an = sign; do not press <return>

e Click in the wkstudy workbook
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e Click on the cell you want to link -- in this case B2; a marquee will surround the cell and
the formula will be displayed in the classlist F5 cell.

e Press the <return> key

You are immediately switched back to the classlist workbook -- notice the formula is
filled in.

Finish the link for Sue for the salary (put it in G5) and then continue setting up the links for Amy
(B3..C3) and Tim (B4..C4). You can just type the formulas in if you don’t want to switch back
and forth between the worksheets.

e In the wkstudy workbook, change one of the salaries and one of the departments

Notice the entries are updated in classlist.

Admin\citstaff\instruct\macintosh\excel 2004 database
7/2/04
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